Windows Server Security Update

Scheduled for Nov 22, 00:00 - 08:00 CST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 19, 2025 - 15:27 CST

Scheduled

IT Services will perform planned server security update maintenance on all UITS-managed production Windows servers between midnight and 8 a.m. on Nov 15.
Posted Nov 19, 2025 - 15:21 CST
This scheduled maintenance affects: IT Systems (Windows Servers).