IT Services aware of issues with Box

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Jun 17, 2026 - 15:45 CDT

Identified

IT Services is aware that users are experiencing issues with Box. For more information, visit the Box status page. https://status.box.com/
Posted Jun 17, 2026 - 14:45 CDT
This incident affected: File Storage & Sharing (Box).