Printing temporarily unavailable in Walton, Law School computer labs

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 11:06 CDT

Identified

Due to maintenance, printing is temporarily unavailable in university computer labs including Walton College of Business and School of Law. An update will be posted when available.
Posted Aug 28, 2026 - 09:06 CDT
This incident affected: Computer Labs & Printing (Student Printing).