Reports of connectivity issues to several resources

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 16:08 CDT

Investigating

IT Service is investigating issues connecting to several resources.
Posted Jul 10, 2025 - 08:28 CDT
This incident affected: Campus Network (Wired Network).