Issues with Zoom

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 18:00 CDT

Investigating

Zoom is investigating issues. IT Services is aware of the widespread issue and will update when Zoom is restored.
Posted Apr 16, 2025 - 14:30 CDT
This incident affected: Collaboration Tools (Zoom Meetings).