Certificate renewal issue affecting Kumo

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 16:06 CDT

Identified

IT Services is working through a certificate renewal issue affecting Kumo. During this time, Kumo's drive-mapping service for resources such as Box, Local Shares and OneDrive may be unavailable. We are evaluating both service scope adjustments and an alternative certificate renewal approach. We will provide updates as they become available.
Posted Jul 01, 2026 - 14:54 CDT
This incident affected: File Storage & Sharing (OneDrive, Kumo, Windows File Share, Box).