Reports of network issues

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 10:01 CDT

Investigating

IT Services is investigating network issues related to printing and other services.
Posted Apr 14, 2025 - 09:26 CDT
This incident affected: Campus Network (Wired Network).