Lab Printing Currently Down
Incident Report for IT Status Monitor
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 16:33 CDT
Investigating
We are experiencing issues with Papercut, lab printing is currently down. We are working to resolve this issue as quickly as possible.
Posted Mar 12, 2024 - 13:56 CDT
This incident affected: Computer Labs & Printing (Printing (PrintSmart)).