Reports of issues adding new Kaltura videos to courses in Blackboard

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 15:28 CDT

Identified

IT Services is receiving reports of issues with adding new Kaltura videos to courses in Blackboard. Both Blackboard and Kaltura have been notified of the issue.
Posted Jul 03, 2025 - 12:02 CDT
This incident affected: Teaching & Learning Tools (Blackboard Learn, Kaltura Video).