Printing issue

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 10:44 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2025 - 13:04 CDT

Investigating

IT Services is troubleshooting an issue that is preventing printing on certain devices related to the recent network outage. Staff are in contact with the vendor.
Posted Apr 15, 2025 - 09:02 CDT
This incident affected: Computer Labs & Printing (Staff / Administrative Printing).