Issues with inbound, outbound Teams calling

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 13:45 CDT

Investigating

IT Services is working to resolve issues with inbound and outbound Teams calling.
Posted Jun 19, 2026 - 12:02 CDT
This incident affected: Collaboration Tools (Teams).