Reports of Microsoft 365 issues

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted May 06, 2025 - 11:14 CDT

Investigating

Microsoft is investigating issues with multiple Microsoft 365 services and features. See the Microsoft 365 Status (https://x.com/MSFT365Status) for more information.
Posted May 06, 2025 - 09:46 CDT
This incident affected: Collaboration Tools (Teams).