IT Services aware of Workday issues

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 14:56 CST

Identified

IT Services is aware of issues affecting Workday access and performance. Workday Support Services is engaged with Workday to resolve the issue as quickly as possible.
Posted Feb 10, 2026 - 11:28 CST
This incident affected: Administrative Services (Workday).