Workday running slower than normal

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 11:28 CDT

Investigating

Workday is currently running slower than normal. The team is working on the issue and will provide updates as they become available.
Posted Aug 03, 2026 - 12:34 CDT
This incident affected: Administrative Services (Workday).