IT Services investigating issues with legacy UAConnect system

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted May 28, 2026 - 10:00 CDT

Investigating

IT Services is investigating issues with the legacy UAConnect system.
Posted May 22, 2026 - 12:44 CDT
This incident affected: Administrative Services (UAConnect).