Cloudfare issues affecting Flowbird parking app

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:45 CST

Monitoring

IT Services and Transit and Parking are aware that the Flowbird parking app was impacted by an outage related to Cloudfare issues this morning. If you experience lingering issues with the Flowbird app and need to pay for parking in the meantime, you can use the university's Text2Pay option by texting the phone number on the signage displayed in the lot you are parking. https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 09:22 CST
This incident affected: IT Systems (Other).