Wi-Fi issues on 4th floor of Kimpel Hall

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 11:42 CDT

Investigating

IT Services is investigating Wi-Fi issues on the fourth floor of Kimpel Hall.
Posted Aug 26, 2026 - 10:05 CDT
This incident affected: Campus Network (Wi-Fi).