Reports of issues with Help Portal

Incident Report for IT Status Monitor

Resolved

This incident has been resolved.
Posted Nov 10, 2025 - 16:36 CST

Identified

IT Services is aware that there are issues with the Help Portal. The vendor is investigating. For more information, please visit the Team Dynamix status monitor: https://status.teamdynamix.com/
Posted Nov 10, 2025 - 08:50 CST
This incident affected: IT Systems (Ticketing System).