Workday Currently Unavailable
Incident Report for IT Status Monitor
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 09:12 CDT
Investigating
Workday is currently unavailable. We are investigating the issue and will provide updates as they are made available.
Posted Oct 01, 2024 - 13:00 CDT
This incident affected: Administrative Services (Workday).